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SOLIDWORKS (SW) is a 3D parametric solid-modeling mechanical CAD program.  SW was developed in 
the United States and was first released in 1995.  It is presently owned by the French company, Dassault 
Systemes Solidworks Corp.  It is estimated that SW is used by 3.2 million engineers at 240K companies 
worldwide (2021). 
 
Solidworks has some associated software including: 
1. Edrawings - a collaborative tool 
2. PDM – manages CAD data, allows concurrent work on designs (teams < 11), maintains design history. 
 
There are similar MCAD (mechanical CAD) programs including: 
1. CATIA (also by Dassault Systemes) 
2. Creo (Pro/E or Pro/Engineer) 
3. Unigraphics (NX, by Siemens) 
4. Autodesk Inventor 
 
Solidworks has the following features (other parametric solid modeling programs are similar): 
1. Parametric – dimensions drive the geometry 
2. Design intent – parts retain "design intent" of designer even after changes are made 
3. Feature-based – the building-blocks of the parts are discrete and changeable 
 
Solidworks has 3 modes: part, assembly, and drawing. 
1. Part – a single 3D solid or a surface (the 2 "physical" entities that can be created) 

Parts also include construction geometry (planes, points, and sketches that don’t exist physically) 
2. Assembly – several parts that are assembled using geometric constraints (mates) 
3. Drawings – drawings of parts or assemblies 

 
1.1 Access to Solidworks 

 
SAC has Solidworks installed on various computers on campus including computers in the engineering 
classrooms, manufacturing technology classrooms, and the Academic Computing Center (ACC).  SAC 
engineering students enrolled in certain classes can also obtain a student version of SW for free.  Codes are 
needed and can be provided by your engineering or manufacturing instructor.  Generally codes are only 
provided to students in certain classes (mainly drafting).  The download is about 8 Gb.  Licenses last for one 
year.  After that you may upgrade to the next version of SW if you are still a SAC student. 
 
 

1.2 Initial SW Settings 
 
Upon initial install, set as follows: 
 
UNITS    IPS (inch-pound-seconds) 
DIMENSION STANDARDS ANSI 
 
Show the Menu Bar by toggling the arrow, and then pin it. 
 
The TASK PANE is along the right side of the SW interface.  Close 
it by clicking in the main area. 
Restore the task pane by clicking on one of the tabs 

Units and Dimension Standard

Select the initial settings for the default templates:

OK Cancel

Units:

Dimension standard:

IPS (inch, pound, second)

NOTE: These settings can be changed for individual
templates or documents in Tools, Options, Document
Properties.

Help

ANSI

x
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If you missed the units and dimension standards at this initial window they may be changed later in the 
DOCUMENT PROPERTIES. 
 
Set the SW Dimension Standard to ANSI, the standard for the US.  Note that this unfortunately does not 
translate to the SW templates.  We must manually make chose changes in the "Document Properties".  See 
SOLIDWORK CUSTOMIZATION in a later chapter.  It is a good idea to create a custom set of templates 
right away. 
 

1.3 SW Interface 
 

Office ProductsEvaluateFeatures

SolidWorks   File    Edit  View    Insert    Tools

Sketch Trim
Entities

A

*

Smart
Dimension

Convert
Entities

Offset
Entities

Mirror Entities

Linear Sketch Pattern

Move Entities

Display/Delete
Relations

Repair
Sketch

Quick
Snaps Rapid

Sketch

*Trimetric

? X

Sketch DimXpert

Part1 (Default<<Default>)

History

Sensors

Annotations

Material <not specified>

Front Plane

Top Plane

Right Plane

Origin

Command Manager

Task
Pane

Feature Manager
Tree

Heads Up View Toolbar

Menu bar menu bar pinned

SolidWorks Resources

Getting Started

New Document

Open a Document

Tutorials

What's New

General Information

Introducing SolidWorks

SolidWorks Tools

Property Tab Builder

SolidWorks Rx

Performance Benchmark Test

Compare My Score

Copy Settings Wizard

Community

Customer Portal

xxxx

Solidworks 2022 Editing Part IPS  
 
 

1.4 SW Settings 
 
There are 2 basic SW settings: 
 
1. System options - settings tied to the SW installation on the 
computer 
2. Document properties - settings tied to templates (one each for 
part, assembly, & drawing).  Changes made here only apply to the 
CURRENT document.  If you don't want to repeat the changes on 
the next document, you must alter or create a new template. 

(instructions below). 
 

Settings may be manually set or imported (if you have desired settings saved to a file). 
 

SolidWorks 2022

SolidWorks 2022 x64 Edition

SolidWorks Tools

SolidWorks Copy Settings Wizard

Start
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1.5 Opening New Part 

 
Open a New Part (File > New > Part > OK). 

File    Edit  View   Insert    Tools

New...

 File

Open ...

 

New Solidworks Document

Templates Tutorial

Part Assembly Drawing
 

1.6 Basic Controls 
 
In part and assembly mode, you must be able to pan, zoom, and 
rotate the model. 
 

Rotate view – push scroll-button down and drag 
Pan – push scroll-button down, hit CTRL key, and drag 
Zoom – roll the scroll wheel 

 
View Orientation Changes (press SPACE BAR) 

View selector (the glass box) – turn off by clicking 
Orthographic views (front, top, right, etc.) 
Isometric 
Normal to 

 
 
After pressing SPACE, the SW "View Selector" Cube will appear.  You can use the View Cube by selecting 
one of its faces to re-orient the view of your part.  You can turn off the View Cube in the dialog box. 
 

1.7 Command Manager 
 
The command manager is generally essential and should appear. 
If it does not you can get it to show using the following steps 
 
Tools > Customize > Toolbars (tab) > [x] Enable CommandManager 
 
 

1.8 Printing 
 
You are most likely going to only print drawings.  And you are most likely to print 2 ways:  

 
1. Directly to a printer 
2. To PDF file. 

 
A pdf file can be printed on almost any computer.  The computer does not need SW installed. 
 

Orientation X

Normal to

Pictorial
view
(eg - isometric)

Orthographic views

View selector box

Zoom
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However you will generally want all lines to print BLACK.  SW encodes DRIVEN dimensions as grey, but 
you don't want those printing grey.  Here are some ways to get that done. 
 
 
STEPS printing from SW to a printer 

1. Print (File > Print, or ctl-P) 
2. Under printer properties select (x) Black and White 
3. Press OK to print 
 

STEPS printing to PDF 
1. Change the display of driven dimensions 

(Properties > System Options > Colors > Dimensions Driven > (set to BLACK)) 
2. Print to pdf 
3. You may wish to reset that Driven-color dimension back to grey. 
(note - System Options are tied to the installation on your computer, not to templates, so once set, you 
should be good). 
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******* SKETCHING ******* 

 
 

 

CHAP 2 -  SKETCHING 
 
Sketches are 2-dimensional (2D) graphical entities drawn on flat surfaces.  Sketches are often the first step to 
producing 3D geometry. 
 
2.1 Sketching First Steps 

 
To create a sketch click the "Sketch" tab in the command manager.  There you will see a variety of 2D 
entities to select (lines, arcs, circles, splines, etc.).  Select an entity.  You will be presented with 3 default 
planes: Front, Right, and Top. 
 
Sketches are drawn on flat surfaces.  At this point, there is not part geometry to draw on, so most users will 
sketch on one these default planes.  Or you can create a plane to draw on.  Pick one (it highlights orange) to 
draw on it. 
 

Features

Sketch Trim
Entities

A

*

Smart
Dimension

Sketch

Front Plane

Top Plane

Right P
lane

 
 

It is easiest to sketch with the sketch plane "normal to" your viewing perspective.  To change this, press the 

space bar to get the ORIENTATION DIALOG BOX.  Select the NORMAL TO icon .   The 2 red arrows 
are the sketch origin. 
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Top Plane
origin

 
 

You can sketch a shape with any combination of lines, arc, and splines.  However, the sketch must be 
CLOSED if it is to be used to create a solid.  It cannot be OPEN, have extraneous lines, or crossing lines.  
Use the REPAIR SKETCH feature if you can't find your error.  SW 2017 introduced "Shaded Sketch 
Contours" where a properly closed sketch would be shaded.  This can be turned off as shown. 

CLOSED SKETCH
(GOOD)

OPEN SKETCH
(BAD)

EXTRA LINE
(BAD)

CROSSING LINES
(BAD)

 

Shaded
Sketch
Contours

 
 

Because of the parametric nature of SW it is often a good idea just to get the general shape/geometry correct 
and worry about the exact dimensions later since these can be changed. 

 
 

2.2 Fully-Defined Sketches 
 
A SW user will generally use a variety of sketch entities to complete 
the geometry of a sketch (lines, arcs, etc.).  Best practices are to 
make the sketch FULLY DEFINED.  This means that the user 
specifies all of the DIMENSIONS and GEOMETRIC CONSTRAINTS to fully constrain the sketch, making 
it completely un-ambiguous.  This means the sketch has no missing dimensions or information.  A fully 
defined sketch appears completely black.  Plus "fully defined" will show in the lower right of the SW 
window. 
 
In contrast, an UNDER-DEFINED sketch has missing information (dimensions, geometric constraints, etc.).  
Thus, the sketch is ambiguous.  An under-defined sketch shows BLUE and the sketch feature shows a (-) in 
the feature tree.  It is possible to reveal the missing constraint by selecting portions of the sketch and 
dragging.  This can be tricky though as you must grab the correct item. 
 

Editing Sketch IPSFully Defined
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1.500

1.000

under-defined sketch fully-defined sketch

- Sketch1

 
 

2.3 Sketch Constraints and Relations 
 
SKETCH RELATIONS are the little green boxes that indicate geometric constraints or relations like: 
HORINZONTAL, VERTICAL, TANGENT, COINCIDENT, CONCENTRIC, CO-LINEAR. 
 

 

Vertical

Horizontal

Concentric

Tangent

Co-linear

2

2Coincident

 
 

2.4 Chain of Lines 
 
Create a chain of lines by selecting the line command and then just left click, move mouse, L click, move 
mouse, etc. 

 
 

2.5 Reference Lines 

Reference Line

 
Solidworks will present reference lines while you are sketching.  These are intended to assign various 
geometric and alignment constraints (like AutoCAD "OSNAPS").  Suppress by pressing "Ctrl" key. 
 
 

2.6 Geometric Constraints 
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Concentric – arcs and circles share same center 
Co-linear – 2 lines lie on the same infinitely-long "line" 
Perpendicular – 2 lines that are 90 degrees rotated from each other 
Co-incident – share the same point 
Sometimes used for co-planar, co-linear 
 
 

2.7 Power Trim 
 
Select the power trim button and drag the mouse (L click) to move the cutting cursor. 

Trim
Entities mouse

path

Result

 
 

2.8 Splines 
 
Splines are smooth curves that are created that pass through the points you select. 
Double click the last desired point. 
Press the ESC key if you clicked one point too far. 
 
 

2.9 Fully Define Complex Sketch 
 
(Tools > Dimensions > Fully Define Sketch) 
 
Sometimes a complex sketch can be tricky to fully define. 
Solidworks can automatically define the sketch (i.e., add dimensions) 
 
 



Page 11 of 38 
 

 

 
******* BASE & SKETCH-BASED FEATURES ******* 

 
 

CHAP 3 -  BASE & SKETCH-BASED FEATURES 
 

 
3.1 Base Feature 

 
The base feature in SW is the first feature, or starting point.  It must be created with a sketch.  The 
orientation of the base feature may NOT be changed if you dimension to the default planes (front, right, top).  
Thus, sometimes it is best to create a plane and draw on IT rather than one of the default planes. 
 

Feature (Sketch2)
Edit Sketch
Edit Sketch Plane       Edit Sketch Plane

    
 

 
3.2 Sketch-Based Features 

 
Generally we can think of these functions as taking 2D geometry (the sketch) and creating 3D geometry from 
it.  There are 6 basic ways of creating sketch-based features. 
 

1. Extruded boss/base 
2. Revolved boss/base 
3. Extruded cut 
4. Revolved cut 
5. Sweeps 
6. Lofts 
 
 

3.2.1 -  Extruded Boss/Base 
 
Extruded boss/base takes a CLOSED sketch and EXTRUDES it into a solid, generating material.  Generally 
you draw a closed 2D sketch and extrude along a line perpendicular to that sketch, thus creating 3D 
geometry. 
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EvaluateFeatures

Extruded
Boss/Base

Sketch

      Boss-Extrude

From

Direction 1

Direction 2

Revolved
Boss/Base

1.00

Sketch Plane

Blind

1.00 inD1

 
  

 
STEPS 
1. Create a CLOSED sketch 
2. Pick Extrude Boss/Base (Features > Extrude Boss/Base) 

- you get a yellow preview if you are ok 
3. Pick the end condition (Direction 1 > xxx) and distance 
4. Click OK (green check) 
 
The resulting extrusion depth is BLUE since it's not defined in the sketch but instead in the extrude feature 
parameters. 
 

3.2.2 -  Extruded Cut 
 
Extruded cut is much like extruded boss/base but instead of creating solid material, it removes it.  It takes a 
CLOSED sketch and EXTRUDES cuts (removes) material from a solid.  Generally you draw a closed 2D 
sketch and extrude along a line perpendicular to that sketch, removing material from a previously-existing 
solid. 
 

STEPS 
1. Create a CLOSED sketch 
2. Pick Extrude Cut (Features > Extrude Cut) 

- you get a yellow preview if you are okay. 
3. Pick the end condition (Direction 1 > xxx) and distance. 
4. Click OK (green check) 
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3.2.3 -  Revolved Boss/Base 
 
Revolved boss/base takes a CLOSED sketch and REVOLVES that about an axis into a 3D solid.  The sketch 
must have an axis (or line) and a solid sketch on ONE side of that line.  
 

STEPS 
1. Create an axis and a CLOSED sketch that lies entirely on one side of that axis. 
2. Pick Revolved Boss/Base (Features > Revolved Boss/Base) 

- you get a yellow preview if you are okay. 
3. Pick the end condition (Direction 1 > xxx) and angle. 
4. Click OK (green check) 

 
 

3.2.4 -  Revolved Cut 
 
 

Revolved cut is much like revolved boss/base but instead of creating material it removes it.  It takes a 
CLOSED sketch and REVOLVE cuts that from an existing solid. 
 
The sketch must have an axis (or line) and a solid sketch on ONE side of that line.  
 
STEPS 
1. Create an axis and a CLOSED sketch that lies entirely on one side of that axis. 
2. Pick Revolved Cut (Features > Revolved Cut) 

- you get a yellow preview if you are okay. 
3. Pick the end condition (Direction 1 > xxx) and angle. 
4. Click OK (green check) 
 

3.2.5 -  Sweeps 
 
A SWEEP is an extrusion of a PROFILE along a curved PATH. 
 
Generally you need a closed sketch and a guide curve that usually starts perpendicular to the closed sketch. 
 
This feature may be used for things like tubular features (like in a min-baja design). 
 

STEPS 
1. Create a closed sketch and also a 3D line. 
2. Pick Sweep (Features > Sweep) 
- you get a yellow preview if you are okay. 
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3. Pick the end condition (Direction 1 > xxx) and angle.  ??????????????? 
4. Click OK (green check) 

 
 

3.2.6 -  Lofts 
 
A LOFT is also much like a sweep but shape is based on multiple close sketches (profiles) that are generally 
different shapes and a guide curve the lives in 3D space. 
 
This feature may be used for things like tubular features (like in a min-baja design). 
 

STEPS 
1. Create a closed sketch and also a 3D line. 
2. Pick Sweep (Features > Sweep) 
- you get a yellow preview if you are okay. 
3. Pick the end condition (Direction 1 > xxx) and angle.  ??????????????? 
4. Click OK (green check) 
 

SWEEP

s

LOFT

Guide curve
or centerline

Profiles

 
 
 

3.3 Zero-Thickness Solids 
 
Zero-thickness solids are considered impossible geometries in SW.  If you sketch a circle that tangent to a 
line and try to extrude it, you will get an error.  This error can also occur with other constructs. 

 

.500 What's Wrong? X

Cut-Extrude1 Unable to create this feature because it would
result in zero-thickness geometry

CloseHelpShow errors Show warnings Display What's Wrong during rebuild

Type Feature Description



X
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******* PART DIMENSIONING ******* 

 
 

 

CHAP 4 -  PART DIMENSIONING 
 

Dimensioning in SW is "smart".  It creates the desired dimension based on the context of the items you select. 
 
 
4.1 Arc Conditions 

 
You can dimension to different ARC conditions.  Press SHIFT with the cursor in the following positions. 
 

1.  Minimum - between the 90 degree window 
2.  Center - outside the 90 degree window 
3.  Maximum - moved to the imaginary 90-degree window (on far side of circle) 

 
 

R4.500 R4.500

1.75
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4.2 Circle or Slot Dimension Options 

 
Simply clicking the 2 circles will produce a center-to-center dimension. 
To dimension to the outside or inside of the circle hold the SHIFT key while selecting. 
Select by clicking NEAR the area of circle you want to dimension to.  For example, click near the outer area 
to dimension to the outside of the circle. 
You can dimension from outer to center by holding shift while selecting the outer part of the circle, then 
releasing shift and clicking the second circle. 

 
 

+ +

5.000
default

5.000

(1) Hold SHIFT
while clicking
in this area

(2) Hold SHIFT
while clicking
in this area

 
 
 
 
 
 
 
 
 
 

 

 
******* PARTS ******* 

  
 

 

CHAP 5 -  PARTS 
 
A part is a single object in SW.  A part is the combination of a sequence of discrete features.  All of the features 
and their sequence are summarized in the FEATURE MANAGER TREE.    
 
5.1 Chamfers 

 
Chamfers are beveled edges. 
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5.2 Fillets 
 
Fillets are rounded edges.  Fillets can be problematic with intersecting edges. 
 

 

CHAMFER ROUND
(called a Fillet in SW)  

 
5.3 Hole Wizard 

 
STEPS 
Select a surface FIRST 
Use the hole wizard (don’t just draw a circle) 
Different types (counterbore, counter-sink) 
 
Add a cosmetic thread (gives the dashed lines) w/o callout 
Place second hole 
Add relations – horizontal 
Is it horizontal or vertical (use pre-defined views, or look at orientation of dimension callouts) 
 
 
 

5.4 Reference Geometry 
 
Sometimes we create reference geometry (planes, surfaces, lines, points) to aid in our creation of part 
geometry. 
 
Create offset planes, then create a plane thru line & pt 
 
Pick axis (intersection of 2 planes, pick 2 planes).  Gives intersection 
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Plane 1

Plane 2

Plane 3

Plane 5

 

Plane 1

Axis1

Plane 2

Plane 3

    Plane
    Axis
    Coordinate System

 
 
 

 

 
******* ASSEMBLIES ******* 

 
 

 

CHAP 6 -  ASSEMBLIES 
 
Assemblies are produced when you assemble multiple parts together.  Assembly occurs by applying 
GEOMETRIC CONSTRAINTS which are called MATES.  An assembly is also summarized in the FEATURE 
MANAGER TREE as a sequence of assembled parts and their mates. 
 
 
6.1 Starting an Assembly 

 
In "bottom-up" design, assemblies are generally created starting with the parts. 
First open the part that will be the first part of the assembly.  Make sure the part window is the active one. 
Go to File > Make assembly from part. 
Check the origin. 
 
Bring in (check graphics view) 
Place the part so that the origin of the assembly is coincident with the part's origin (you see the double 
arrows).  Helps to have origins showing (View > Hide/Show).  Can hide origins after inserting first part. 
 
In the FEATURE TREE you should see an "(f)" next to the part (where (f) = fixed). 
 
Note you can unfix using "FLOAT".  Unfixed parts show "(-)" 
 
Window > Tile Horizontally (so you can see all the open parts). 
Pick the second part and drag it into the assembly. (or use Assembly tab > Insert Part) 
It helps to rotate the part close to the correct orientation. 
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6.2 Mates 

 
"Mates" is the term for the GEOMETRIC CONSTRAINTS that fit one part to another one.  Inserting a pin 
into a hole would be a mate of CONCENTRICITY.  Mates may result in under-constraint, which would 
result in movement of the assembly.  This is a really cool feature in SW.  Assemblies can be machines that 
move (like an internal combustion engine).  That's why this type of program is essential for mechanical 
engineers. 
 
It is very easy to create constraints that conflict with each other, or ones that over-constrain the assembly.  
This requires a lot of thought to resolve. 
 
 
COINCIDENT 

Has many meanings 
 
CONCENTRIC 
 
CO-PLANAR 
 
GEAR MATES  
 
These will sometimes work if you do it right.  Eg, if you spin the screw, the jaw moves. 
 
DISTANCE 
 
 

6.3 Explodes 
 
Assemblies can hide components, and they can be difficult to see how the parts fit together.  One technique 
for addressing this is to EXPLODE the assembly.  You may have seen this in instructions for assembling a 
piece of furniture.   SW constrains one part to another one.  Inserting a pin into a hole would be a mate of 
CONCENTRICITY.  Mates may result in under-constraint, which would result in movement of the 
assembly.  This is a really cool feature in SW.  Assemblies can be machines that move (like an internal 
 
STEPS 
1. Click part 
2. Click axes, apply 
3. Done 
4. Explode line sketch 
5. Click on screw 
6. Click 
 
 

6.4 Adjusting Parts Based on Assembly 
 
Bottom-up design is almost always taught and learned first.  It's easier to comprehend and easier to form the 
assembly.  However, the challenge of bottom-up design is making the small dimensional changes at the part 
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level so the assembly comes together as desired.  Often you will find yourself tweaking part dimensions until 
something lines up as desired. 
 
It may be helpful to add a dimension to the assembly to help aid you in determining how much to change a 
part dimension to obtain some kind of alignment. 
 
 
 
 

 
******* DRAWINGS ******* 

 
 

 

CHAP 7 -  DRAWINGS 
 
Drawings may be produced from individual parts or of assemblies.  Drawings also have their own version of the 
FEATURE MANAGER TREE.  In the case of drawings, the tree defines the drawing as dependent on a part 
and the various created views of the part.   
 
7.1 Sheet Formats 

 
Sheet formats contain the border, title block, and other settings. 
 
EDIT SHEET FORMAT 
 
(RH click white space > Edit Sheet Format) 
Text in sheet format is only editable while in "Edit Sheet Format" (like paperspace in AutoCAD). 
 
OTHER ITEMS 
 
Part 

File > Properties > Custom (e.g. – metal 6061-T6) 
Drawing 

Edit sheet format 
Highlight field 
Part name – link to file name 
Notes – view dependent vs. independent 

Sections 
Draw the line first (align the holes, view/temp axes) 

Creating Fields (File > Properties > Custom) 
Make field 
Highlight letters 
Click button 
Props/ custom 
Student text 0000000 

Or views from drawing 
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Insert model 
Highlight model 
Choose first view (front) 
 
 

7.2 Drawing Scale 
 

(RH click white space > Drawing scale). 
 
 
 

7.3 Detail Views 
 
 

(Insert > Drawing View >  Detail) 
 
Drag out a circle.  Adjust its center point 
Set style: 

Per Standard 
Broken Circle (use this)  

Set scale (e.g., 4:1) 
Detail view includes a label: "DETAIL A: SCALE 4:1" (this can be deleted if desired) 
Detail view can be moved to desired position on drawing 

 
 
 

7.4 Section Views 
 

Drawing

Standard
3 View

Model
View

View Layout

Projected
View

Auxiliary
View

Section
View

Detail
View

A

 
 
Draw the line first. 
Then pick on section view (make sure it's 3rd angle standard) 
 

7.5 Revolved Sections 
 
STEPS 
1. Place view 
2. Draw line on the view 
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3. Use line to create a section 
4. Remove the "Section A-A" notation (select and delete) 
5. Right click the cutting-plane line > Hide 

Hide Cutting Line

Edit Sketch

Properties ...

Smart Dimension
 

6. Break the view – set the gap and line style 
7. Move the section into the break area 

Broken View Settings

1.5in

Break line style:

Curve Cut

     
 

7.6 Removed Sections 
 
1. Create the section as usual. 
2. Break the alignment (RH click section view > Alignment > Break Alignment) 
3. Move the section view to the desired location 
 

 

View (Drawing View 3)

Lock View Position
Lock View Focus
Isometric Section View

Reset sketch visibility

Alignment Break Alignment

Align Horizontal by Origin

Align Vertical by Origin

  
 
 

7.7 Half or Offset Sections 
 
1. Create the section as usual. 
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B. Aligned sections – draw a kinked line first.  Aligns to the 2nd (1st?) line selected. 
C. Spoke/rib rules – SW has no clean way of taking out the hatching.  Must draw 
1. Sketch 2 boundary regions.  Then create an Area Hatch/Fill.  Use Line Format menu to change the color 
of the fill to white. 
 
 

7.8 Auxiliary Views 
 
Draw the line first then select the auxiliary view command. 
Click to place the view. 
 
SECONDARY AUXILIARY VIEWS 
 
 
 

7.9 Drawing Dimensions 
 
AUTOMATIC DIMENSIONING  
 
(Insert > Model Items > Dimensions) 
 
SW can automatically insert dimensions based on dimensions specified in the part.  Note the dimension will 
not appear if you don't have the proper view already inserted.  Dimensions inserted are DRIVING 
DIMENSIONS, which can alter the part.  Many companies only allow DRIVEN dimensions to appear on 
drawings.  You can convert these dimensions to be driven. 
 

Select dimension 
(Properties > Other (tab)) 
 

 
MANUAL DIMENSIONING 
 
(Smart Dimension) 
 
Manual dimensioning inserts driven dimensions which appear gray (this can be changed in settings). 
When printing, select "Black and White" (or dims will be in grey). 
 

7.9.1 -  Radius vs. Diameter 
 
You can switch between radius and diameter 

 
RH click dimension > Displays Options > Display as Radius (or Diameter) 

 
7.9.2 -  Spherical dimensions 
 
You must simply add an "S" to the dimension. 
Select the dimension.  In the dimension options > Dimension Text > (add an S before the items there) 
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7.10 Drawing Features 

 
 

7.10.1 -  Oblique Extension Lines 

1.1

.50

 
STEPS 
 

1.  Click the dimension 
2.  Grab the extension line grip 
3.  Drag 

 
7.10.2 -  Jogged Extension Lines 

1.1

.50

 
STEPS 
1. Right click extension line 
2. Display options > Jog 
 

7.10.3 -  Virtual Sharps 

 
STEPS 
1. Pick one line. 
2. Hold Ctrl key and pick 2nd line. 
3. Pick the point (*) 
 

 
7.10.4 -  Arcs 
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Select the start point of the arc. 
Select the end point of the arc. 
Select a point between the 2. 
Place the dimension. 

 
7.10.5 -  Chamfers 

 
RH click the 45, then the edge, then pull out the dim 

 
7.10.6 -  Centerlines 

 
CL – don’t use 
Dim CL – pick target symbol 

 
7.10.7 -  Hole callout  
 

Must have used the Hole Wizard 
 

7.10.8 -  Symmetrical centerlines 
 

Draw short fat lines on your own (workaround) 
Screw 
Relative view 

RH click sheet/ drawing views/ rel views 
Bent leader length 

 

Bent leader length
(change to .125 from .25 default)

 
 View/ temp axis (get *) 
Edit – RHC line 
Offset 
Select this 
Use templates 

 
7.11 Title Block Fields 

 
The fields in a SW sheet format are parametric, and so you don't alter them the way you might think. 
Alter them by entering: 
 
(File > Properties > Sheet Format). 
 
 

7.12 Assembly Drawings 
 
Drawing 
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Import 2 of them (will convert configur of 1) 
Props/ uncheck show exploded state 
Hide all (temp axis, origins) 
Balloons 
Formatting them 
BOM 
Edit sheet format 
Click upper left, RHclick, set as anchor, BOM 
Back to sheet 

RH click 
Table / BOM 
Anchor (upper right) 
Change col width – just drag 

Part 
Props 
Config specific 
Add/change 

 
 

7.13 Printing 
 
Generally you will want to print in BLACK 
(File > Print > Print options > Color (set to Black and White)) 
 
 
 
 

 
******* ADVANCED TOPICS ******* 

 
 

 

CHAP 8 -  ADVANCED TOPICS 
 
 
8.1 Freeform Surface Modeling 

 
I. Freeform (Insert > Surface > Freeform) 
A. Step 
1. Pick surface 
2. Add curves > LH click to add 
3. Flip Direction (tab) 
4. Add curves > LH click to add 
5. Add points > LH click to add points 
6. Unclick add points, click a curve, select point and drag 
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8.2 Gears 
 
STEPS 

1.  Draw root, base, pitch, and outside circles (use Excel table to get the diameter values). 
2.  Set them as construction 
3.  Draw radial lines to base circle - horizontal, half angular pitch, full angular pitch (e.g., 4.5 & 9 deg) 
4.  Draw radial line that is 2X pitch (18 deg) 
5.  Draw involute as equation-driven curve 
6.  Set up equations (tools > equations > global variables) 
7.  Diametral pitch (P), number of teeth (n), pressure angle (phi), addendum (a), dedendum (d) 

Clearance, c (b-a) 
7. Pitch diameter, PD 
8. Base circle dia,  
9. When doing the equation-driven curve, must reference the dimension 
a. Can’t reference global variables 
 
I was previously able to create a gear model with INVOLTE shaped teeth.  This requires creating 
EQUATION-BASED CURVES.  Years ago I had trouble mirroring the curve but was eventually able to do 
it by copying the curve, mirroring it, then mirroring it again.  In SW 2022 I tried to duplicate this but could 
not.  The mirrored curve was not parametric.  This I could not solve.  There is an option to simply pull in a 
gear from SW mechanical components library.  This did not work either.  The model was not parametric. 
 
I solved the problem by estimating the involute with a 3-point curve.  This works well enough and the gear 
model is changeable. 
 
 

8.3 Categories 
 
1. Fractional 
2. Props/ use doc units (uncheck)/ units 
3. Type in as "5/16" 
4. Units 
1. 50 mm 
2. Converting – tools/ option/ doc props 
 

8.4 Tolerancing 
 
Bilateral - for xx  xx 
 
STEPS 

1.  Click dim, switch between dia (xxx) or depth (xxx) (confusing!) 
 
 
8.5 Fillet 

 
CONSTANT WIDTH 
- Constant width (looks nice) 
 
VARIABLE RADIUS 
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- Suppress already-done features 
- Variable radius 
- Nodes – eg. 5 (different radius value at each node) 
- Set all 
 
FACE FILLET 
- Face fillet 
- face fillet 2 
Surface 1, surf 2, and hold line 
Aesthetics! 
With variable thickness part 
Fill in 
Body fillet 
 
FULL ROUND 
(select 3 surfaces in right order) 
 

8.6 Surface Cut 
 

A SURFACE CUT allows you to cut a part using a surface (flat or not flat). 
(Surfaces > Cut with Surface). 
 
 

8.7 Shell 
 

 
 
The SHELL feature takes a solid and hollows it out.  The resulting "shell" part is often the type of part that 
may be injection molded. 
 
(Features > Shell) 
Then select a shell thickness. 
Then select a surface (the side that the shell is OPEN TO). 
  
 

8.8 Wraps 
 
Tools/ customize 
Font – pts (auto changes units and space) 
Insert/features/wrap 
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How to 
Select surface 
Emboss – sticks out 
Deboss – goes in 
Scribe – written on 

 
8.9 Equations 

 
Relates different dimensions 
 
STEPS 

1.  Select dimension 
2.  Tools/ equations 
3.  "Dimension Selected" = xxx 
4.  Result: dependent equations have a "sigma" () in front 

 
Configuration tables 
1. Dimensions for part drawn from table (Rob may not cover) 
    
Linking 
1. Pick dim 
2. RHclick/ link values 
3. Share values (give dim a name, eg "top width") 
4. Pick a 2nd dim 
5. Neither controls 
6. Global to part 
 

8.10 "Vary Sketch" Patterns 

 
 

Instead of a linear or circular pattern, a VARY SKETCH pattern creates a pattern based on a sketch. 
This is basically done when a DIMENSION is used for the pattern direction.  Only then does the "vary 
sketch" option become available. 
 
Create feature to be patterned 
Linear Pattern 
1. Direction 1 

For direction, open the feature pick the dimension that offsets the feature from the side wall 
Do NOT pick the lower edge (which is what we would normally do) 
Pick distance and number of instances. 

2. Under Options > check "Vary sketch".  Preview still does not look right. 
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3. Click "Full preview" (instead of Partial Preview) and it will look right. 
 
    
a. Can create a sketch (don’t create a feature from it), then use it later 
 

8.11 Saving image 
A. Do from drawing mode (on blank format), doesn’t work fm dwg mode 
B. Save as jpeg 
C. Adjust DPI 
D. Import to MS Word, crop, compress 
 

8.12 GD&T 
 
Datums 
Basic dimensions – by double clicking dimension 
Feature control frame 
 
 

8.13 Surfaces 
 
SW surfaces have no thickness or mass.  Often they are used as construction geometry or references for 
creating part material. 
 
Insert/face/delete – you go from 1 solid body to 1 surface body 
 

8.14 Top-down assembly 
 
Assembly is the parent 
2 spheres (concentric) 
Remove inner sphere – so you get a cavity 
Split 
1. insert/feature/split 
2. hide vs. show 
3. create new parts 
 
E. Make new assembly 
F. Make part in assembly 
G. Make a mold 
H. Import door – move it up in the tree 
I. Edit part (mold), edit sketch 
 
PARTIAL TOP-DOWN 
 
Create parts with tab/slot assembly.  Must position slots so parts position properly.  Example would be to 
create tabs on part, pull into assembly, position properly.  Then create slot features on the plate using the 
tabs. 
 
CREATING A SET OF HOLES 
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One small top-down example is creating a set of mounting holes on a base plate for - for instance - an 
Arduino circuit board.  The Arduino board is already modeled with proper hole spacing.  One option is to get 
into the base plate part and match the dimensions on the Aruino part.  This works but is a pain.  A second 
option is to create an assembly that includes the base plate and Arduino.  Mate the Arduino to the base plate 
as desired (onto surface, distance from 2 edges).  Then make holes in the plate using the following steps: 

 
1. Edit Part > Select base plate 
2. Sketch on plate surface 
3. Create a set of circles that are concentric with Arduino holes (may need "temporary axes" shown) 
4. Size the holes 
5. Extrude cut the holes 
6. Exit the "Edit Part" mode 

 
The part will have the mounting holes now, even if you just open the base plate part alone. 
 
 

8.15 Extrude to surface 
 
IV. Create a container (fm 1 part) 
1. Create a "cup" type part (surface)  
2. Create 2 configurations (inner thicken, outer thicken) 
 

8.16 Extrude to Multiple Surfaces 
 
Must KNIT surfaces first (Surfaces menu > Knit surface) 
 

8.17 Over mold 
 
STEPS 

1.  Cut sweep 
2.  Select ALL surfaces 
3.  Offset plane 
4.  Trim – also extends (corner) 

 
KNIT 
Knit makes 2 surfaces one 
 
VI. Insert/boss/base 
VII. Display relations 
VIII. Olive drab = a problem! 
IX. Replace Face 
 
 

8.18 Global variables (use a dummy sketch) 
 
Create a dim on a "useless" sketch 
Link/shared value – give name 
Equations – click on sketch to get the dim 
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8.19 Mini baja – piping 

 
STEPS 

1.  Sketch offset plane 
2.  Select, select chain 
3.  Convert entities 
4.  Another sketch 
5.  Draw circle 
6.  Horizontal bar – extend sketch so extrusion goes thu 
7.  Extrude 
8.  Do first, sweeps can be disjoint 
9.  Mirror 
10.  Split 
11.  Do same with the top 
12.  Parts have the "fish mouth" 
13.  Make drawing 
14.  Put in centerlines 
15.  Can put pts at cl intersections to dimension 
16.  Shelling? 

 
 

8.20 Ordinate dimensioning 
 
Ordinate dimensioning is when all dimensions originate from a single point.  This is a good technique for 
sheet metal where tolerances are not critical. 
 
(RH click a view > More Dimensions > Ordinate) 
 
Click the first edge. 
Draw out dimension. 
Click subsequent edges 
 
  

8.21 Draft Angle 
 
DRAFT ANGLE tapers one side of the part.  This feature is often used for molded parts as the taper makes 
extraction from the mold easier. 
 
STEPS 

1.  Select draft 
2.  Pick neutral plane (doesn't change) 
3.  Pick faces to draft 
4.  Pick direction (arrow points in direction of convergence) 
5.  Or can draft during extrusion 
6.  Can draft just 1 side 

 
 

8.22 Breaks 
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STEPS 

1.  Highlight view 
2.  Insert/drawing view/vertical break 
3.  Position break lines 
4.  RH click view/break view 
5.  Adjust scale on sheet 

 
8.23 Ribs 

 
STEPS 

1.  Select plane 
2.  Select line 
3.  Rib (normal to, thickness) 
4.  Rib extrapolates to walls (stops at other rib if sketch is per right below) 

   
PARALLEL RIBS (ribs parallel to sketch) 
1. Highlight sketch, press ‘rib’ 
2. Parallel to, thickness 
3. Will extrapolate (right pic) 
4. Warning – sketch cannot go all the way to corners (or error) 
  

8.24 Design table 
 
STEPS 

1.  Click dim/more props 
2.  Name… change it ("width@Sketch1") (can also name the sketch!) 
3.  Note – name your features in a useful way 
4.  Insert/design tables 
5.  RH click dim/props 
6.  Dim – get a table 

 
8.25 Booleans 
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******* SW CUSTOMIZATION ******* 

 
 

CHAP 9 -  SW CUSTOMIZATION 
 
Once you have SW set up the way you like, you can save those 
settings to use on another computer.  This is the COPY SETTINGS 
WIZARD.  Once done, this saves a "swSettings.sldreg" file. 
 
Go to: Start > All Programs > Solidworks 20xx > Solidworks Tools 
> Copy Settings Wizard 20xx 
 
If you are on a new or reformatted computer, you can install SW 
and set up the settings either MANUALLY (see below) or 
IMPORTED using the COPY SETTINGS WIZARD.   
 
Go to: Start > All Programs > Solidworks 20xx > Solidworks Tools > Copy Settings Wizard 20xx 
 
It saves a swSettings.sldreg file.  This file can then be used to import those SW settings to another computer. 
To IMPORT settings, follow the same steps but pick "Restore Settings". 
 
Import settings – same steps as above but pick "Restore Settings". 
 

SolidWorks Copy Settings Wizard

CancelNextBack

This sizard allows you to save or restore customization settings for SolidWorks
toolsbars, shortcuts, menus, and system preferences

Choose which task you would like to perform

Save Settings -
         Save the SolidWorks 20xx settings for XX to a file

Restore Settings -
       Restore SolidWorks settings from a file

Welcome to the SolidWorks Copy Settings Wizard

SO LID W O R K S

 

SolidWorks Copy Settings Wizard

CancelNextBack

Choose a location and name for the settings file (*.sldreg)

Save these settings

Keyboard shortcuts

Save Settings to File

S O LID W O R K S

Menu customization

System options

Toolbar layout

All toolbars

Macro toolbar only

Saved Views









BrowseC:\Users\UserName\Documents\xxx.sldreg

  
 
 

9.1 System Settings 
 
System Settings – These options are tied to the SW installation on a computer, not to the template files. 
System Options (Tools > Options > System Options (tab)) 
 
Here are some settings that CT does (these are optional) 
 
1. Display Style > Tangent Edges > Use Font (default is Visible) 
2. Colors – Change the paper color to white (default is yellowish) (Colors > Drawings, Paper Color) 

SolidWorks 2022

SolidWorks 2022 x64 Edition

SolidWorks Tools

SolidWorks Copy Settings Wizard

Start
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Customize X

Toolbars Shortcut Bars

Category: DeleteAll Commands

?

Commands Keyboard Mouse Gestures CustomizationMenus

Copy List

Show: All Commands

Search for:

Reset to defaults

Description

OK Cancel Help

Category Command Shortcut(s) Search shortcut

File

File

New...

Open

Ctrl+N

Ctrl+O

 
 

9.2 Keyboard Shortcuts 
 
(Tools > Customize > Keyboard tab) 
 
Keyboard shortcuts for view changes can really speed up your work. Note SW shows the keyboard letter in 
CAPS even though you’ll enter in lower case. 
 
CT’s keyboard shortcuts (shortcuts work for both left or right side mousing) 
View /Zoom to fit    (add J, F is default) 
View/ Zoom to Area  (L, S… must remove L fm tool/line) 
View / Zoom to selection  (K,D) 
View / Rotate   (U, R) 
View / Pan    (P) 
Others/ Isometric   (I) 
Insert/ mate    (M)  (for assembly mode) 
Tools/compon.rotate    (N) (for assembly mode) 
Others/normal to   (O) (as in orthogonal) 
Edit / Rebuild   (B) 
 

9.3 Custom Toolbars 
 
(View > Toolbars > ) 
 
The command manager "ribbon" along the top is standard.  However, you can also add and customize 
toolbars. 
 

9.4 Customized Templates 
 
SW comes with a default set of part, assembly, and drawing templates.  However you can create and 
customize your own. 
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A key setting to change is the DIMENSION STANDARDS.  While we have set the dimension standard at 
the start of the installation process as ANSI, it does not seem to propagate to the SW templates.  It is also 
suggested that you set the default display of dimension places at 3 (X.XXX). 
 
There are 3 default templates in a specific file location.  Those templates are: 

 
Part.prtdot 
Assembly.asmdot 
Drawing.drwdot 
 

You are free to open any of these templates, make changes, and then save those as NEW templates.  It is 
suggested you do not over-write the default ones though.  Save the new altered ones with a slightly different 
name in the same SW templates folder.  They will then appear when you go to create a new part, assembly, 
or drawing. 
 

 
9.4.1 -  New Part Template 
 
STEPS 

1. Open a new part (File > New > Part) 
 
Make settings changes below (Tools > Options > Document Properties) 
2. Change Dimension Standard to ANSI for all items under [+] Dimensions 

(Tools > Options > Document Properties > Dimensions) 
Under each item XXX under dimensions, set "Base XXX dimension standard to ANSI), 
Where XXX is: angle, angle running, arc length, chamfer, diameters, hole callout, linear, 
ordinate, radius. 

3. Dimensions display set to 3 places (Dimensions > Primary Precision) 
4. Save as new template (e.g., Part_AA.prtdot) (keep original template) in default directory 

(C:/ProgramData (hidden)/Solidworks/Solidworks20xx/templates) 
 

The new template should now appear as an option when you make a new part. 
 
 

9.4.2 -  New Assembly Template 
 
STEPS 

1. Open a new assembly (File > New > Assembly) 
2. Cancel out of any automatically-opening windows (part selection, etc.) 
 
Make settings changes below (Tools > Options > Document Properties) 
3. Change Dimension Standard to ANSI for all items under [+] Dimensions 

(Tools > Options > Document Properties > Dimensions) 
Under each item XXX under dimensions, set "Base XXX dimension standard to ANSI), 
Where XXX is: angle, angle running, arc length, chamfer, diameters, hole callout, linear, 
ordinate, radius. 

4. Dimensions display set to 3 places (Dimensions > Primary Precision) 
5. Display the origin (View > Hide/Show > Origins) (helpful when pulling in first part) 
6. Save as new template (e.g., Assembly_AA.asmdot) (keep original template) in default directory 

(C:/ProgramData (hidden)/Solidworks/Solidworks20xx/templates) 
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The new template should now appear as an option when you make a new assembly. 
 
  

9.4.3 -  New Drawing Template 
 
STEPS 

1. Open a new drawing (File > New > Drawing) 
2. Cancel out of any automatically-opening windows (sheet format, views, etc.) 
 
Make settings changes below (Tools > Options > Document Properties) 
3. Change Dimension Standard to ANSI for all items under [+] Dimensions 

(Tools > Options > Document Properties > Dimensions) 
Under each item XXX under dimensions, set "Base XXX dimension standard to ANSI), 
Where XXX is: angle, angle running, arc length, chamfer, diameters, hole callout, linear, 
ordinate, radius. 

4. Dimensions display set to 3 places (Dimensions > Primary Precision) 
5. Make visible lines THICKER (Line Font > Visble Edges > 0.0138) (change fm 0.0098) 
6. Dimension Text - shrink it (Dimensions > Font > 0.100) (change from 0.125) 

Font - keep as Century Gothic (but Simplex is an option?) 
7. Save as new template (Draw_AA.drwdot) (instead of Drawing.drwdot) in default directory. 

 (C:/ProgramData (hidden)/Solidworks/Solidworks20xx/templates) 
 

The new template should now appear as an option when you make a new drawing. 
 
 
CHANGE PAPER COLOR - this is a SYSTEM option (Colors > Drawings, Paper Color) 
 
 

9.4.4 -  Custom Drawing Sheet Format 
 
Solidworks has its own sheet formats, but you can create your own custom one if you want. 
Open a new drawing.  Select a SW sheet format that is close to what you want. 
Edit the format (RH click in white area > Edit Sheet Format). 
Edit the border and title block as desired. 
 
Some title block fields use a simple text block.  In that case you fill in the field manually by clicking the text 
box and typing in what you want. 
 
Other title block fields are "smart" in that they auto-populate.  STEPS to do this: 

 
1. Create a text block.  Clear it out. 
2. On right pane, select "Link to Property" 
3. Click "File Properties" - a number of pre-written properties appear.  You can create your own too. 
4. Once set up, go to Properties, enter property values --> sheet format will update 
 
Sheet Format > Title Block Fields ... 
Select the new fields to add to Title Block fields (fields turn blue) 
The list on the right pane can be re-ordered so you can tab thru the fields more quickly. 
(you don't have to go to Properties window any more) 
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Once set up, and then you open a PART using this sheet format.  If the part has "meta-data", it will all 
automatically populate the title block (e.g., material type, etc). 
 

 

 
******* xxx ******* 

 
 

CHAP 10 -  XXX 
 

10.1 Section 1.1 
 

10.1.1 -  Section 1.1 
 

1.  Renumbers after 1.1  
2.  YES! 
3.   

ct_text1 - Interesting text goes here. 
ct_text2 

ct_text3 
ct_text4 

ct_text5 
 
// ctz_programg 

// ctZ_programg2 
 

Windows default

Autoscroll

X

 No line ending

File    Edit  View   Insert    Tools

New...

 File

Open ...

OK

Templates Tutorial



 


